Clipper help

Miniature Horse Talk Forums

Help Support Miniature Horse Talk Forums:

Taya

Well-Known Member
Joined
Apr 23, 2007
Messages
165
Reaction score
0
Hi

I have a pair of double ks that I purchased second hand. Have new oster blades aswell.

I cant get the blade to attach lol

This is my first pair of clippers so havent done it before but thought they would just click on??

Can anyone give me a run through on how to do it please
 

miniaddiction

Well-Known Member
Joined
Oct 31, 2004
Messages
1,102
Reaction score
0
Location
Auckland New Zealand
Hmmmmm, I dont use oster blades. But did you have the clipper running when you tried to snap the blade on? Always have it running or you will damage your clippers. Other than that, they normally just snap on easy peasy...
 

gatorbait4sure

Well-Known Member
Joined
Feb 20, 2005
Messages
485
Reaction score
2
Location
Harwich, MA
Look at the back side of your clipper head, hold it so the blade part is pointing up. There is a silver ( metal) rectangular part on the back of the blade area that must be pulled away at the top ( the bottom is attached).

This is the flap that holds the clipper on. They drop onto it. If it is closed, and you aren't familiar with clippers, it isn't something you think of.

good luck!

dru
 

Taya

Well-Known Member
Joined
Apr 23, 2007
Messages
165
Reaction score
0
Thankyou both for your replies


Dru - That was the problem lol now you can imagine the trouble I was having trying to get the blade on
Thanks so much
 

Latest posts

Top